DE - Commerzbank having technical problems with Payment
Incident Report for Qwist availability
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 09:51 CEST
Identified
Dear Qwist customer,

Commerzbank is experiencing technical problems with the Payment service on their side, transactions may not be successfully completed.

We will update you as soon as we have further information.

If you have any questions in the meantime, please contact us via partnersupport@qwist.com

Best regards,
Qwist team
Posted Apr 10, 2024 - 09:33 CEST
This incident affected: Connectivity Availability - DE (Commerzbank).