Deutsche Kreditbank (DKB) - full outage for credit card
Incident Report for Qwist availability
Resolved
This incident has been resolved.
Posted Nov 23, 2023 - 15:09 CET
Investigating
Dear finleap connect customer,

we see that we have a full outage with the credit card from Deutsche Kreditbank (DKB) and the users may not be able to connect.

We are investigating this issue, and will update you as soon as we have further information.

If you have any questions in the meantime, please contact us via partnersupport@finleap.com

Best regards,
finleap connect team
Posted Sep 28, 2022 - 16:45 CEST
This incident affected: Connectivity Availability - DE (DKB).